Welcome to PhotoSweeper
“Do you really need all 12 shots of that coffee
table?”

PhotoSweeper helps you organize your photo collections by finding and grouping duplicate or
similar photos using powerful comparison settings.
It works with Apple Photos*, Adobe Lightroom** and Capture One libraries, as well as photos
from your hard drives.
If you have questions about PhotoSweeper or seek solutions, it is the to contact us by e-mail:
support@overmacs.com
We are always eager to get any requests and suggestions from you. We would like to thank all
users who have contributed to the development of PhotoSweeper by sending questions, bug
reports, and sharing ideas.

* Apple iPhoto and Aperture are supported too.
** Lightroom Classic CC is supported. Lightroom CC (the cloud-based version) is not supported.
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Getting Started
Browser

Shows all added photos.

Info panel

Preview, histogram and metadata.

Toolbar
Provides quick access to the most
commonly used functions.
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Basic steps to remove duplicate or similar photos
1. Choose mode
Click Single List Mode on the Welcome screen.
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2a. Add photos from your Photos library (if you use Apple Photos)
Сlick Media Browser on the toolbar to show the Media Browser window. Add your library to this
window by pressing "+" and choosing your Photos library in the open panel. The Media Browser
displays a library content, including photos, albums and moments.
Select photos in the Media Browser window and drag & drop them to the main window, or just
press the "up arrow" button. You can drag a whole library, a moment/album, or photos. Photos
should be shown in the main window with a green “ribbon” and a Photos icon on each.
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2b. Add folders from your Mac (if you keep photos in folders)
Drag & drop a folder to the main window to find all photos inside it (including photos in
subfolders). Drag another folder, if needed.
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3. Compare your photos
Press Compare and select what to find:
•

Duplicate Files - search for absolutely identical files.

•

Similar Photos - find photos which look similar. Time Gap determines an interval between
photos and you can set its value from zero seconds to infinity. Matching Level defines the
level of photos similarity and can be changed in the Results on the fly.

•

Series of Shots - combine photos into groups, based on a time gap between photos.
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4. Review results and mark photos for removal
The Results mode displays all found duplicates in groups, and it's up to you which photos to
mark for further removal (usually you only need to keep one photo for each group). You can do it
either automatically by pressing Auto Mark on the toolbar, or manually by selecting each photo
and pressing Enter.
When you press Auto Mark on the toolbar, all photos in each group, except one, are marked
according to the rules defined in Preferences. For instance, if you have 4 photos in one group, 3
will be marked for removal and 1 will be kept. The Auto Mark rules determine which photo in
each group to keep. By default, the Auto Mark rules are configured to keep the largest image.

marked
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5. Move marked photos to Trash
Click Trash Marked and confirm removal. Upon removal, files go to the system trash, while items
from Photos - to the Trash (PhotoSweeper) album.

Important: You need to delete all photos inside the Trash
(PhotoSweeper) album manually. Follow how to steps below in this
manual.
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Adding photos in details
You can add photos from your Mac and Photos, Lightroom and Capture One libraries.

To add photos from your hard drive drag and drop a folder with your photos
from Finder into the browser, or press Command+O to show the standard
Open panel. All photos inside a folder will be found and added.

To add photos from Photos, Lightroom, or Capture One click Media Browser
on the toolbar. The Media Browser window appears with previously added
libraries, their albums and photos. At the first launch you may need to add your
library files to the Media Browser window by using the “+” button. Drag and
drop photos you want to compare from the Media Browser window to the
browser.

In the browser, photos from libraries are marked with a green “ribbon” at the top-left corner.

from Apple Photos
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from a hard drive (a file)
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Warning: Close Photos, Lightroom and Capture One applications before
using PhotoSweeper in order to synchronize library content. If a library is
being changed while PhotoSweeper is launched, close a native
application and press the refresh button in the Media Browser window.

To remove photos from the Photo List select them in the browser and use the menu Photos >
Remove Photos from List, or press Command+Delete.
To fast empty the Photo List click Clear List on the toolbar.
Hint: You can quit PhotoSweeper at any time and resume the app at the same stage
with the same photos. Upon launching the app, just press Restore Last Session to
restore the photo list and comparison results.
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Comparison Settings
PhotoSweeper provides powerful settings, allowing you to find:
•

Duplicates Files - search for absolutely identical files.

•

Similar Photos - find photos which look similar. Time Gap determines an interval between
capture dates, and you can set its value: from zero seconds to infinity. Matching Level defines
the level of photos similarity and can be changed in the Results on the fly.

•

Series of Shots - combine photos into groups, based on a time gap between photos.

Hint: Comparison of photos can take quite a long time and depends on how many
photos you add and what settings you use.
While receiving results, PhotoSweeper saves loaded bitmaps and stores them in a cache in order
to make the next bitmap loading of the same photos extremely fast.

Page 11 of 32

PhotoSweeper

Similar Photos: Advance settings
You choose how to compare photos: Bitmaps method compares pixels of size-reduced images,
Histograms method compares histograms.
Small bitmap size increases comparison speed and reduces memory usage, while large bitmap
size delivers more precise results. Blur Radius allows you to smooth edges on photos.
Hint: Bitmap Size 48x48 is usually enough to get satisfactory comparison results.
Using bigger bitmaps takes significantly more memory and is not recommended for a
large photo list.

Hint: Align Colors preprocessing helps you find duplicate photos even after applying
color adjustments, such as contrast, brightness, white balance, auto levels, etc.

Hint: Using Grayscale color mode dramatically decreases comparison time.
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Reviewing results
You can review groups in 3 modes:
• One by One: one large image is shown. This mode allows you to fast switch between photos
in a group to capture a difference and mark/unmark a photo with just a click.
Back button

Groups view
Displays result groups and
allows you to select one.

Switch
between modes

Matching Level
Allows you to regroup
photos “on-the-fly”.

Photos in a group

To navigate quickly between photos press ←, → keys; ↑, ↓ - to navigate between groups.
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• Face-to-Face: two large photos from one group are displayed with more details, such as
image metadata, file paths, capture dates, etc. Mark/unmark a photo with just a click.

Back button

Groups view
Displays result groups and
allows you to select one.
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Switch
between modes

Matching Level
Allows you to regroup
photos “on-the-fly”.

Photos in a group
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Face-to-Face mode also allows you to compare metadata information by pressing Info on the
toolbar. Different values are marked red.

To mark either left or right photo using a keyboard press Shift+← or Shift+→, for navigation
between photo pairs press Command+←, Command+→.
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• All-in-One: allows you to see all groups together, but with fewer details.

Back button

Switch
between modes

Matching Level
Allows you to regroup
photos “on-the-fly”.

Browser
Displays all photos grouped, with headers for
groups and thumbnails for photos.
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Marking photos
The browser displays marked photos with the red bottom and “Trash Bin” badge added in the
corner. To mark or unmark photos select them and press Enter key, or simply double-click.

marked photo

unmarked photo

The One by One and Face-to-Face modes allow you to mark or unmark with just a click.
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Auto Mark
You have an opportunity to mark all photos automatically with just one click using Auto Mark on
the toolbar. PhotoSweeper marks all photos in each group, except one, based on rules defined in
the Preferences window.

If you want to skip a rule, uncheck it; to set the rule order - drag and drop rows.
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How Auto Mark rules work
For instance, there are 5 similar images in one group with rules applied, as shown on the
screenshot below.

When you press the Auto Mark button, firstly, 5 photos are compared based on the rule #1. In
this case it's Source. In this sample each photo is a file, therefore the next rule is applied.
Next rule #2, Rating. In the sample given, 3 photos have 5-star rating. As a result, 2 photos
without rating are marked, and the rest 3 photos are compared using the next rule.
Next rule #3, Dimensions. There are 2 photos of 1500x1000 pixels and 1 photo of 750x500. As a
result, 1 photo of smaller dimensions is marked, 2 photos are compared using the next rule.
Next rule #4, File Size. One of the two photos has a less file size, therefore it’s marked. Thus, one
photo is left, and the job is done.
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In the end, you have 4 photos marked for removal, keeping the 5-star rating photo of the largest
dimensions and size.

* fever stars

* smaller file size
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* smaller dimensions

* fever stars
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Other features
You can mark all photos in a group by using the menu Selected > Mark Whole Group(s).
Often you need to mark all photos from a group with an exception of one or two. For this
purpose you can select photos you want to keep and use the menu Selected > Mark Group(s)
Except Selected Photos.
To quickly unmark all photos use the menu Photos > Unmark All.
You also have an opportunity to select photos located in the same place: a containing folder for
files from your Mac, an album, or an event for photos from Photos. All you need to do is select
one photo and use the menu Photos > Select Photos within.

Hint: You can mark photos in Photo List mode as well. To switch between Photo List
and Results modes press Control+1 and Control+2, or use the View menu.
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Moving marked photos to Trash
To remove all marked photos press Trash Marked on the toolbar and confirm removal. The
progress bar shows the start and the end of the process, as photos go to trash.

Apple Photos
As a result, photos are in the album named Trash (PhotoSweeper). All photos are still stored
where they used to be.
You need to delete all photos inside the Trash (PhotoSweeper) album manually, it’s not the same
as removing photos from the album, or removing the album. After manual deletion, all photos
are deleted from all locations, including iCloud, iPhone, iPad etc. To trash photos, follow these
steps:
1. Launch Photos application.
2. Select the Trash (PhotoSweeper) album (you can use the sidebar to select; to show the
sidebar use the menu View > Show Sidebar).
3. Select all photos (you might need to wait for some time, up to 5 minutes, Photos app
sometimes doesn’t select all photos until all previews are generated).
4. Click the menu Image and press and hold the Command key. Important: you should see the
menu Delete Photos (not Remove Photos from Album).
5. Click Delete Photos. Photos will go to Recently Deleted.
6. Delete photos in Recently Deleted. Now, when these steps are completed, photos will be
removed from all locations, including iCloud.
Please note that real files are being deleted in the background (even when Photos application is
not open) and this process may take some time.
Watch YouTube video showing the process.
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Lightroom

Important: Lightroom application must be closed until removal is
finished.

As a result, photos are moved to the collection named Trash (PhotoSweeper) and are also
marked as Rejected.
Next time you launch Lightroom the collection Trash (PhotoSweeper) is pre-selected. To get rid
of photos select all of them and, holding Command and Shift keys, use the menu
Photo>Remove and Trash Photos.
Another possible option is to remove Rejected photos: select the All Photographers catalog and
use the menu Delete Rejected Photos.

Capture One

Important: Capture One application must be closed until removal is
finished.

As a result, photos are moved to the Capture One trash.
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Side to Side mode
Side to Side mode lets you find duplicates between two groups of photos while ignoring
duplicates inside each group. It allows you to compare the contents of two folders with each
other, or to find photos similar to a single image.
You can add files, folders or libraries to either group. All photos inside a folder and library will be
found and compared.

Hint: Use the Lock Photos option on the left side or right side to protect previously
sorted folders or libraries.
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Advanced features
Marked Photos mode
You have an opportunity to see only marked photos in a separate mode. Use the menu Marked >
Show Marked Photos or press Control+3 to get into the Marked Photo mode.
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Renaming photos while moving or copying
You can set meaningful file names to your photos while moving or copying them using the menu
File > Move to Folder and Rename or File > Copy to Folder and Rename.
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Image Info
Sometimes basic information about photos is not enough to decide which one to keep. To show
advanced information about the photo selected, click Info button on the toolbar.
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Movies
In addition to photos, you can also compare video files. Follow the same steps to find duplicate
movies as you do with photos, including possibility to add movies from Photos, Adobe
Lightroom and Capture One libraries.
In the browser movies are marked with a “camcorder” badge at the bottom-right corner.

Warning: PhotoSweeper finds absolutely identical video files only,
regardless of comparison settings you choose.
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Locked photos
There’s also an option to lock photos. Locked photos are used for comparison, but they can’t be
marked for deletion. To lock or unlock photos select them and press Command+L, or use the
menu Photos > Lock.

Locked photo
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When you add photos you can lock all images from a specific folder automatically using settings
in the Preferences window.
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Searching photos in the browser
In addition, you can search photos in the Photo List mode using different criteria. To show or hide
the filter panel press Find Photos on the toolbar or Command+F.
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Filtering photos while adding
You can skip small images or files in specific image/video formats using settings in the
Preferences window. These options are for photos being added to the browser.
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